HOME        ABOUT
FORUMS        FAQ

0 Trophy Bug Repro Case

0 Trophy Bug Repro Case

Postby DKDev_Chris » Tue Jan 09, 2018 11:48 am

Hi all,

I'd like to reach out to the community for help with reproducing the "0 Trophy Bug" for one of our Engineers to examine. If you are not familiar with the issue, please see more information here.

If you encounter this bug, please immediately send me a PM and include the following information:

Your User ID (found in the Settings menu, but don't post this information publicly. PM only.)
The Dungeon name and Guild name of your opponent
An approximate time of occurrence.

Also, feel free to use this thread if you have any questions regarding this issue.

Thank you very much!
DKDev_Chris
Developer
Developer
 
Posts: 779
Joined: Wed Oct 01, 2014 3:25 pm

Re: 0 Trophy Bug Repro Case

Postby pitofdespair » Tue Jan 09, 2018 7:41 pm

I think I’ve mentioned this before, but just in case...I’ve only seen this once myself (but heard several others). It didn’t seem to be a cheater. One thing I noticed is that it didn’t actually seem to have anything to do with the person having zero trophies - when I attacked they had trophies (I normally check to avoid attacking newbies), and when they revenged me they had a couple of thousand (not likely enough time to gain so many). So I suspect it showing zero trophies is a side-effect, just as showing zero gold/stone is a side effect. I’ve attacked zero trophy people without having a problem a couple of times.

My best guess is that there’s a null value being returned due to a fault somewhere in the process of storing or retrieving the raid. Perhaps due to the account being locked at that time, as the person logs in, another person simultaneously attacking/revenging them, or something like that. It returns or stores a blanked/nulled person (not raid - the spell/etc. info is there so the raid itself seems okay), so without the person to store in the raid it shows zero trophies/gold/stone (because the blank person has none to take).

Less likely, the person on the other end is cheating and has modified values that are crapping out the db somehow.

Just some thoughts... it may be related to zero trophy people, it just doesn’t seem like it in my experience.
Bruce Campbells Army of Darkness - an open lv 40 guild for casual players of all levels who want to develop their dungeons and get Dreadstone in tournaments
pitofdespair
Master Keeper
Master Keeper
 
Posts: 516
Joined: Wed Aug 20, 2014 4:45 pm

Re: 0 Trophy Bug Repro Case

Postby LegendaryOnesCom » Fri Jan 12, 2018 5:25 pm

Never happened to me before, but pitofdespair have a point.
DCR211 | 11,981 Trophies | Skar Tactics | Working on my own fantasy game: http://www.legendaryones.com/blog
LegendaryOnesCom
Newbie
Newbie
 
Posts: 22
Joined: Mon Apr 24, 2017 4:11 pm

Re: 0 Trophy Bug Repro Case

Postby pitofdespair » Wed Jan 17, 2018 2:28 am

Just a note, saw someone post a screen shot the other day where they attacked a player, won, same player came up for them just a few minutes later, and hit zero trophy bug defeating them again. Same name - and the target player was around 10k trophies so very unlikely a clone the second time (though cloning I suppose could be an issue).

I’ve noticed (forever) that matching frequently throws the same person at you exactly twice within a few nexts. Not sure if they then go to the back of the queue, but won’t see them for hours, if not days. Wondering if it’s possible that someone is attacked, defeated, should be in cave-in, but gets served up a second time due to this fluke. That is, when I next someone they shouldn’t come up again right away, but they often do - maybe this problem has spread to include people in cave-in for some reason. Then when the second raid goes to be stored, it finds the player in cave-in and throws a fault, resulting in a null player being returned and all the zeros.

Not likely related of course, but just a thought, after seeing that the second attack pulling the bug when the first on the same target was totally fine. Doesn’t seem like the target player as such is a problem.
Bruce Campbells Army of Darkness - an open lv 40 guild for casual players of all levels who want to develop their dungeons and get Dreadstone in tournaments
pitofdespair
Master Keeper
Master Keeper
 
Posts: 516
Joined: Wed Aug 20, 2014 4:45 pm

Re: 0 Trophy Bug Repro Case

Postby Mishko » Sat Jan 27, 2018 4:03 pm

Today i have another one

https://youtu.be/lQxkNhcvWvY
Ukraine
User avatar
Mishko
Newbie
Newbie
 
Posts: 1
Joined: Tue Dec 06, 2016 5:56 am

Re: 0 Trophy Bug Repro Case

Postby pisus » Thu Jun 28, 2018 2:06 pm

Captain here.
It's just the old glitch not being definitely fixed, like usually. If you begin the raid exactly the same moment the last minion is created, in the old times the resupplies were for free without paying any gem. Of course this couldn't be figured out how and engineers put a patch on it adding only a string. If this happens, you create an error and it disconnects you at the end of the raid, so you cannot resupply everything for free. Not a great solution if it happens casually, but it works for those who did it on purpose.
*Flies away*
User avatar
pisus
Minion
Minion
 
Posts: 52
Joined: Mon Jun 08, 2015 8:22 am

Re: 0 Trophy Bug Repro Case

Postby Phoenix71 » Sat Sep 08, 2018 2:27 am

Hello, I've been a DK player for years. And love the game. I'm writing because there's an issue I ran into today that I've never seen. The Guilds are not loading. I have a white flag, not my Guild flag. And when I click on the white flag I get a message that says "Guild are currently unavailable". Plus when I go to battle I get a message that says "Tournaments Unavailable, Tournaments are currently unavailable. You will not earn tournament stars in this raid". I've never encountered this before. It loaded properly yesterday morning. Is there an issue? Thanks.
Phoenix71
Newbie
Newbie
 
Posts: 1
Joined: Sat Sep 08, 2018 2:16 am

Re: 0 Trophy Bug Repro Case

Postby purgatoria » Tue Sep 11, 2018 8:07 pm

Phoenix71 wrote:Hello, I've been a DK player for years. And love the game. I'm writing because there's an issue I ran into today that I've never seen. The Guilds are not loading. I have a white flag, not my Guild flag. And when I click on the white flag I get a message that says "Guild are currently unavailable". Plus when I go to battle I get a message that says "Tournaments Unavailable, Tournaments are currently unavailable. You will not earn tournament stars in this raid". I've never encountered this before. It loaded properly yesterday morning. Is there an issue? Thanks.

Guild server crashed. No guild no tournament. This also happens when they do server maintenance
User avatar
purgatoria
Master Keeper
Master Keeper
 
Posts: 873
Joined: Tue Apr 08, 2014 12:11 am


Return to Spells

Who is online

Users browsing this forum: No registered users and 1 guest

Legal Notices    |    Product EULAs & Other Disclaimers    |    Terms of Service     |    Privacy Policy - Your Privacy Rights    |    Corporate Info    |    Online Safety Guidelines

© 2013 Electronic Arts Inc. Trademarks belong to their respective owners. All rights reserved.