Crash when open Imps screen to slap them

Please provide as much detail as possible, so that we can attempt to reproduce.

Crash when open Imps screen to slap them

Postby Manii Names » Sun Apr 23, 2017 10:25 am

Issue: When I open the imp screen to slap them the game says "loading imps", then "spike trap upgrade complete", then imps then spikes etc. Loop repeats. I am unable to continue.

What device are you using to access the game? (if you use more than one, please provide the information for all devices used, and an indication as to whether or not the problem you're experiencing is consistent across all devices)

IPad Pro 9.6" and iPhone 6S+' both with iOS 10.3.1.

What version of DK are you currently running?

Not sure how I would check. It's whatever is most current, store says it is in to date.

How are you connecting to the internet? (WiFi, cellular, etc.)

Tried both.

What is the storage situation on your device? Are you near max capacity?


Do you have several other apps running in the background on your device? Have you tried reducing the number? If so, does this seem to have an appreciable effect on your experience?

I rebooted both devices, launched nothing but DK, problem persists.
Manii Names
Posts: 10
Joined: Sun Sep 11, 2016 10:23 pm

Re: Crash when open Imps screen to slap them

Postby purgatoria » Sun Apr 23, 2017 11:40 am

Old bug, one of your spike traps is about to be completed, and you slap em imps initiating the loop. Stop slapping your imps, until the trap is complete.
User avatar
Master Keeper
Master Keeper
Posts: 844
Joined: Tue Apr 08, 2014 12:11 am

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 6 guests

Legal Notices    |    Product EULAs & Other Disclaimers    |    Terms of Service     |    Privacy Policy - Your Privacy Rights    |    Corporate Info    |    Online Safety Guidelines

© 2013 Electronic Arts Inc. Trademarks belong to their respective owners. All rights reserved.