HOME        ABOUT
FORUMS        FAQ

Stone Quarries and Gold Mines double production

Please provide as much detail as possible, so that we can attempt to reproduce.

Stone Quarries and Gold Mines double production

Postby Buccleuch » Fri Nov 03, 2017 4:07 pm

This is an interesting one. Is it a bug, or a feature? My fellow keepers may hate me for this, but here goes...

My info:
Dungeon: Moria, leader of the Unholy Alliance guild
Device: iPhone 6s, iOS 11.1

Issue (follow me on this):

I noticed this oddity as I upgraded my stone quarries (SQ) and gold mines (GM) from level 12 to 13, and now from 13 to 14. I ran a more precise test today as I upgraded my last gold mine to 14.

If the player is logged in and on the server when a GM or SQ upgrade completes, great - the room begins producing that resource at the new rate per the newly-upgraded level capability. Nothing to see here.

BUT...

If the player is NOT logged in at the time the GM or SQ upgrade completes, the newly-upgraded room produces gold or stone AT TWICE THE NEW RATE until the player logs in the first time after the upgrade completed.

Today, I logged out with 30 minutes (real time; build time was at 1 hour, but my imps are slapped religiously) remaining until my GM upgrade from lvl 13 to 14 was to complete. I stayed out of the game for a measured 4 hours and 30 minutes to let stone and gold accumulate in my other lvl14 SQ’s and GM’s, as well as let the lvl13 GM upgrade to 14 complete and begin producing gold.

The result?

My existing lvl 14 SQ’s and GM’s all produced about 49,440 in resources, +/- 8 or 12. Exactly as expected for production over the 4.5 hours at the 11,000/hr rate for lvl 14.

But the newly-upgraded lvl 14 GM - recall that it still had a half-hour yet to go before completing - produced 87,848 in gold in the 4 hours after the upgrade completed! Right at 22,000/hr! Confirmed, at twice the lvl 14 rate.

Once the player logs in after the upgrade to the SQ or GM completes and collects the resources, the room “corrects itself,” and produces stone or gold at the proper rate.

Again, a bug, or a feature? Heh.

Thanks for your work for this community, Chris!
Buccleuch
Newbie
Newbie
 
Posts: 3
Joined: Mon Aug 04, 2014 4:23 pm

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

Legal Notices    |    Product EULAs & Other Disclaimers    |    Terms of Service     |    Privacy Policy - Your Privacy Rights    |    Corporate Info    |    Online Safety Guidelines

© 2013 Electronic Arts Inc. Trademarks belong to their respective owners. All rights reserved.